Mulberry Security Changes and Upgrade

The Mulberry email program on Windows computers must be upgraded before May 1st, 2015 to meet new security requirements. Windows Mulberry users will need to run our new LSIT Mulberry installer and follow our security settings change guide by May 1st, 2015.

Please follow each and every step in our Mulberry Upgrade Guide to make the required changes to your settings

For the Mulberry 3.1.6_LSIT download, please use the username/password you were provided via email.

  • Helpdesk

News Date: 

Friday, May 1, 2015